The verson of sdk is not 2.6.101?


#1

Hi,matt
I have installed the sdk on an arm64 machine ,but it showed that the version of sdk is not 2.6.101.How do I get the latest version of SDK on ARM64?


#2

What version of Ubuntu is this?

Our support policy for binary releases are:

  1. Support x86-64 on the most recent 2 Ubuntu LTS versions (i.e., currently 16.04 and 18.04)
  2. Support armhf, arm64, i386 on the most recent Ubuntu LTS version (i.e., currently 18.04)

If you’re running 18.04 you should be able to grab the latest version (2.6.101)

-Matt


#3

Hello,
I have the same issue using Jetson TX1 and TX2 units, which use an ARM64 architecture. The problem is that the standard JetPack L4T packages provided by nVidia still only provide Ubuntu 16.04, so there is some lag there. Hopefully they will add support for 18.04 in the future, but by then we may already be looking at Ubuntu 20.04 LTS.
Is there a big issue with getting the latest versions to run on previous Ubuntu versions? I know the TX1 (and TX2) versions of OpenALPR are built against OpenCV 2.4 for Tegra (as opposed to 3.1 for x86-64), is there an issue there?
Perhaps I am missing a critical part of the argument to not support 16.04.


#4

Jetson binaries are a special case, we package those in separate repos for each JetPack version. Nvidia publishes new JetPack releases quite frequently which require new binaries (and, honestly, is challenging to keep up with). We support Jetson regardless of the Ubuntu version. Right now we’re supporting JetPack 3.3 (based on Ubuntu 16.04) and JetPack 4.0 (based on Ubuntu 18.04). We plan to support JetPack 4.0 for a longer period, because this supports the new Xavier product and has the bleeding edge TensorRT 5.0 library which has some important optimizations that we will use to greatly improve the speed of the OpenALPR engine. We’ll have a release in March 2019 that will significantly improve performance for Jetson. Our goal for that release is to be able to process two simultaneous 1080p video streams at full framerate on a TX-2.


#5

Thanks for clearing that up, it is indeed challenging to keep up with JetPack releases…

Do you know if the planned March release will have support for JetPack 3.3, or will you have dropped it by then?


#6

Andreas,

JetPack 3.3 is supported in the current version. You can install with:
bash <(curl https://deb.openalpr.com/install)

We plan to continue to support it in the upcoming version as well.


#7

Hi Matt,
Do you have new release to support Xavier?
I have Xavier installed ubuntu18.04 and jetpack 4.1.1(deepstream 3.0, tensorrt 5.0)


#8

Yes, we support Jetpack 4.2 now. The standard install script will point to the correct repo and install the software:
bash <(curl https://deb.openalpr.com/install)


#9

Hi Matt,
I have run install script on Xavier, but it display following message:
…
Hit:16 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease
Get:18 https://deb.openalpr.com/jetson40 jetson40/main arm64 Packages [19.6 kB]
Fetched 27.5 kB in 4s (7,203 B/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package openalpr-web
Installation failed.

how to fix it?

The following items was selected by this installation,
install_webserver
install_agent
install_sdk
install_nvidia
upgrade_software

Need I install so many items? I have install jetpack and only require the “license plate recognition” can be displayed on ubuntu GUI.


#10

You should not choose “install_webserver” for ARM devices – that is only supported on x86-64 machines. The agent and SDK are supported on Jetson.


#11

Hi Matt,
1.Does this release(support Jetpack 4.2) has leveraged deepstream(3.0)?
2.If it dose not, how to leverage deepstream?
3.If I need not install_webserver on Xavier, does alpr/alprd can display on ubuntu GUI?
4.Which one should I run, alprd -f or alpr?
5. When I run alprd -f, it alway display,
2019-05-03 08:09:09 alprd 548295580624: INFO - Using: /usr/share/openalpr/config/alprd.defaults.conf for daemon defaults
2019-05-03 08:09:09 alprd 548295580624: WARN - No stream configuration files found.
2019-05-03 08:09:09 alprd 548295580624: WARN - No licenses found

while I have set “stream = http://127.0.0.1/home/nvidia/Videos/taipei.h264” in alprd.defaults.conf, what is the correct setting to read local video file?

Must I get a two week license? is it not free?