Second URL


#1

How i can configure a Second URL.
In the same server where i have the agent, i have a php server and i want insert in a access database the plate when the agent read it.

i can configured a second url like htpp:\localhost\alpr\test.php?plate=###### where the ####### is the plate and de datetime???


#2

I’m not sure I understand exactly what you’re trying to do. You have a PHP script that you want to run on the agent? Your software will manage the database and also have a web component?

If that is the case you can point the agent to send data directly to your local app (either via a local HTTP POST or you can read from the local beanstalkd queue). Your app can then populate a database and present the data in a web interface however you like.


#3

Change my question I configured the agent through local HTTP POST (http: //localhost/lprd/patentes.php). How i can see the images of the plates. In the pc i have the file 1527785250319.mdb but i can’t open with access. Do you have any program to see the images like the app in the cloud but to run in the pc only to see the images?


#4

You can pull the images locally via the local webservice:
http://doc.openalpr.com/on_premises.html#local-image-retrieval

That is the best method, because it will work in the future even if we change storage mechanisms.

If you want to grab the images directly from the storage system, you can do that as well, although it’s not the best way. The images are stored as JPEG data inside a rolling LMDB database. This is much more efficient use of Disk IO compared to storing the raw files. I have attached two scripts you can use to inspect and retrieve images from these LMDB databases. They’re indexed by time (epoch milliseconds).

lmdb_utils.tar.gz (667 Bytes)

We have also open sourced the code we developed for the rolling storage database, in case the code is useful:


#5

I Matt

I try de pull images via

http://doc.openalpr.com/on_premises.html#local-image-retrieval

But I can’t, I don’t see de port 8355 up
I installed only agent and sdk

Whats is wrong?

Best


#6

Make sure you turn on the local webserver in the agent config (it’s disabled by default). You can do so by editing /etc/openalpr/alprd.conf and adding the following lines:

web_server_enabled = 1
web_server_debug = 1
web_service_bind_address = 0.0.0.0
web_server_port = 8355

The web_server_debug is optional but sometimes helpful for seeing the format for image retrieval. You would want to disable that in production. Also, if you don’t want the port exposed to the outside world, change the web_service_bind_address to 127.0.0.1

-Matt