Docker on Jetson NX Jetpack 4.4

I am trying to install openalpr agent docker on Jetpack 4.4 and have run into some issues. The setup I am after is a local queue with a legacy licence using a code from the system ID. When I use the following from docs:
docker run -P -v openalpr-vol1-config:/etc/openalpr/ -v openalpr-vol1-images:/var/lib/openalpr/ -it openalpr/agent openalpr-licenseregister (Also I add --runtime nvidia, -gpus all isnt supported on jetson)
I only have cloud option, then in the next I only have cloud endpoint:
docker run -P -v openalpr-vol1-config:/etc/openalpr/ -v openalpr-vol1-images:/var/lib/openalpr/ -it openalpr/agent alprlink-register
Finally I get the system ID from the first one and run the container using:
docker run --restart always --runtime nvidia -d --cap-add SYS_NICE -P -v openalpr-vol1-config:/etc/openalpr/ -v openalpr-vol1-images:/var/lib/openalpr/ -it openalpr/agent

But I have errors, the beanstalkd service isnt running and when I restart it doesnt work, if I add a file to the agent to test it doesnt work. I tried to use the gui config using:
docker run --runtime nvidia -it -e DISPLAY=$DISPLAY -v /tmp/.X11-unix/:/tmp/.X11-unix --restart always -d --cap-add SYS_NICE -P -v openalpr-vol1-config:/etc/openalpr/ -v openalpr-vol1-images:/var/lib/openalpr/ -it openalpr/agent:2.8.101-jetson

It brings up the config when I type alprdconfig but its a bit broken and above problems persist.

Hi Gabe,


It looks like there are some residual configuration settings from when you tried to setup the online license. Those will be stored in /etc/openalpr/alprd.conf. Could you please paste the contents of that file so we have a record, and then you can delete all lines and replace them with the recommended configuration for local queue in the documentation. With upload data and websockets off, you should not see any connection attempts in the logs.

By default, the agent checks for licensing through the cloud webserver first, but if you explicitly turn this off it should find your local license key.

Best,