Can't install commercial agent version on freshly installed Ubuntu 18.x LTS

On line 3 fropm manual i have the problem:

wget -O - http://deb.openalpr.com/openalpr.gpg.key | sudo apt-key add -
echo "deb http://deb.openalpr.com/commercial/ trusty main" | sudo tee /etc/apt/sources.list.d/openalpr.list

sudo apt-get update && sudo apt-get -y install openalpr openalpr-daemon
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 openalpr : Hängt ab von: libopenalpr2 (= 2.5.101-20171201181820) soll aber nicht installiert werden
            Hängt ab von: libalprlc2 soll aber nicht installiert werden
            Hängt ab von: libalpropencv3 soll aber nicht installiert werden
            Hängt ab von: libalprlc-utils soll aber nicht installiert werden
 openalpr-daemon : Hängt ab von: libopenalpr2 (>= 2.5.101) soll aber nicht installiert werden
                   Hängt ab von: libalprlc2 soll aber nicht installiert werden
                   Hängt ab von: libalpropencv3 soll aber nicht installiert werden
                   Hängt ab von: libalprstream3 soll aber nicht installiert werden
                   Hängt ab von: libboost-filesystem1.54.0 ist aber nicht installierbar
                   Hängt ab von: libboost-system1.54.0 ist aber nicht installierbar
                   Hängt ab von: libcrypto++9 ist aber nicht installierbar
                   Hängt ab von: libjsoncpp0 (>= 0.6.0~rc2) ist aber nicht installierbar
                   Hängt ab von: liblog4cplus-1.0-4 ist aber nicht installierbar
                   Hängt ab von: librollingdb2 (>= 2.1.0) soll aber nicht installiert werden
                   Hängt ab von: libvehicleclassifier2 soll aber nicht installiert werden
                   Hängt ab von: sysv-rc (>= 2.88dsf-24) ist aber nicht installierbar oder
                                  file-rc (>= 0.8.16) ist aber nicht installierbar
                   Hängt ab von: libalprlc-utils soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

So why??

My German is a little rusty but it looks like you have some missing dependencies. Try looking closer at the packages that are listed as “not installable”. Some (if not all) of them appear to be C++ related. Have you tried the usual

sudo apt-get install build-essential

?
If apt and/or dpkg are still complaining, try looking closer at the specific packages listed, and why apt is refusing to install them.