Agent on Jetson Nano?


#1

I’m trying to switch my agent from Windows to a Jetson nano. Is this supported, or even feasible?

The install seemed to work fine, and the agent is running and linked up to the cloud app which is receiving log data. When I try to add the exact same RTSP feed that works on the Windows install, the “test” function times out after 13 seconds.

Also, I have GPU acceleration enabled in the config, and the log indicates the analysis thread is running on the GPU:

2019-08-19 10:55:04 alprd : INFO - GPU Acceleration detected
2019-08-19 10:55:04 alprd : INFO - Initializing analysis thread # 1 on GPU 0

However, there is zero load on the GPU. I would have expected that if the nano was simply under powered, there would be high load.


#2

Yes, we support Jetson JetPack 4.2 on Nano (not yet 4.2.1).

After installing OpenALPR on Jetson, can you try the following:
wget http://download.openalpr.com/bench/720p.mp4
alpr -g 720p.mp4 --clock

If there is any error it should show up on the command line.


#3

Thanks for the quick response. I was using Jetpack 4.2.1 and reverted to 4.2, but that didn’t work. Same result. When I try to run the alpr command on your test file I get a licensing error, even though the agent is registered with the cloud service.

When I switched the video feed from 264H to mpeg, it started working. Is it a CODEC issue?


#4

Try grabbing a temporary license here:
https://license.openalpr.com/evalrequest/

That should allow you to use the Alpr command directly.

For your h264 stream, are you able to load this into another media player like VLC and make it play?


#5

It was a missing codec issue. It’s working fine after installing the Nvidia accelerated Gstreamer binaries following Nvidia’s user guide:

As a benchmark, the Nano is running 1080p / 10fps just fine on 10W mode.


#6

Did you just run these…

sudo add-apt-repository universe
sudo add-apt-repository multiverse
sudo apt-get update
sudo apt-get install gstreamer1.0-tools gstreamer1.0-alsa \

gstreamer1.0-plugins-base gstreamer1.0-plugins-good \ gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly \ gstreamer1.0-libav

sudo apt-get install libgstreamer1.0-dev \ libgstreamer-plugins-base1.0-dev \ libgstreamer-plugins-good1.0-dev \ libgstreamer-plugins-bad1.0-dev

Did you first remove the gstreamer? I’m having the same issue where the test times out after 13 seconds, its a brand new install of 4.2 and the first thing I did was enabled 8 cores and gpu, then to install openalpr to the cloud server which installed all the gstreamer etc, hopefully via the apt-get commands above.

What code was missing for you and how did you install it?


#7

I did not remove it first. The last thing I did before it started working was run those commands as root. (After I installed OpenAlpr)

I’m not 100% sure, but I think OpenAlpr may assume you have the correct codecs installed already for the streams you want to process. And that installing these packages gives you the Nvidia-optimized codecs. It seems Jetson 4.2 is super stripped down…doesn’t even include CURL.

I also found this to be a handy utility for monitoring the GPU:


#8

Yeah still not working for me, I even tried removing the packages and reinstalling them :confused:


#9

Just done a brand new flash of Jetson 4.2 on Xavier.
Installed Gstreamer as per the instructions
then done “bash <(curl https://deb.openalpr.com/install)”

Wont load my RTSP stream from the cloud :frowning:


#10

The only thing I did differently was reverse the order. I installed OpenAlpr first, and then the nvidia gstreamer code.

I’ve got a new unit coming in a few days and will try installing from scratch again. I did beat the thing with several hammers before the last step got it working. I just don’t remember all of them.

If I were the folks at OpenAlpr, I’d create a pre-configured image that works out of the box.


#11

So I did another clean install. I installed Jetson 4.2, then gstreamer according to the Nvidia instructions.

My test of the RTSP stream FAILED the test (after 13 seconds), but when I added it anyway, it just started working.

So there’s something that can cause the test to fail, but the stream works anyway.